TFS build with AX 2012

Topics: Build Process
Jul 6, 2011 at 6:45 AM

Hi

we need to integrate the TFS build with AX 2012. When we queue the build, the build is sucessfull and the buils output folder contain only the "BuildLog.txt" file.

There is no XPO files present in the output folder. Please any body can help us to get the XPO files in out put folder.

It is good if you share the detail steps telling about how to integerate the build.

Below S/w are used.

AOS: AX 2012

TFS: 2008

 

Thanks

Praveen

Coordinator
Jul 6, 2011 at 5:54 PM

Hi Praveen,

to get anything to show up in the output folder, the easiest way (without modifying the build XAML) is to make sure the XPO gets written to the "Binaries" folder during the build. Your original XPOs from version control will be in "Sources"... you need to go one up and into Binaries. Anything in Binaries will get copied.

Jul 26, 2011 at 10:36 AM

Hi

When i tried to check-in the files from AOT i am getting the error " $/TFSMain/Data Dictionary/Extended Data Types/TeststrEDT.xpo does not meet the quality bar."

I can check-in the files directly from Team explorer  to TFS but not through AOT. There is no any compilaton error or BP error. Please let me know how to fix these issue.

Below S/w are used.

AOS: AX 2012

TFS: 2010

 

Thanks

Praveen

Coordinator
Jul 26, 2011 at 3:39 PM

Praveen,

 

under version control/system settings you have base practice settings. Compiler warnings/compiler errors/to-dos/best practice errors. Also on the system settings, element names and element types can be excluded. If any of these criteria aren't met, you get that "does not meet quality bar" error. Can you check those?

Jul 27, 2011 at 8:52 AM
Hi Joris
we have done the cross check in BP under version control/system settings/General, here all Compiler warnings set to Accept/compiler errors set to Accept/
to-dos set to Accept/best practice errors set to Accept.
In Exclude element Name contains below list.
<\_
<aa
<Action:d+
<Class:d+
<copyof
<Dataset:d+
<delete
<DisplayContentItem:d+
<Form:d+
<Marco:d+
<Map:d+
<MenuItem:d+
<OutPutContentItem:d+
<Report:d+
<Service:d+
<Table:d+
<URL:d+
<View:d+
<WebletItem:d+
<WebMenu:d+
<WorkFlow:d+
In Exclude element Types there is no entries. 
We can able to check-in the same file to Morphx VCS, TFS 2008 and check-in is sucessfull, but same file i cont check-in to TFS 2010, 
it is ending with error "does not meet quality bar".
 
 

Thanks

Praveen